Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 20, 2025 - 16:00 UTC
Scheduled
Our upstream provider will be performing scheduled maintenance involving a PDU replacement at our primary datacenter. We appreciate your patience while this necessary infrastructure upgrade is completed to improve long-term reliability.
Posted Oct 18, 2025 - 18:18 UTC
This scheduled maintenance affected: Zone 2 Controller.